If you see the following error after pkg upgrade or pkg install {anypackge}

Shared object "libdl.so.1" not found 

Your FreeBSD version might be outdated. This currently happens on FreeBSD 11.1 if you use the latest/qarterly pkg mirror.

How to fix it?

freebsd-update -upgrade -r 11.2-RELEASE
reboot
freebsd-update install
pkg update && pkg upgrade

hackacad

a collection of FreeBSD and security related snippets